Good Sam Club Open Roads Forum: no brake lites or hazard but turn signals flicker
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > no brake lites or hazard but turn signals flicker

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
ajriding

st clair

Senior Member

Joined: 12/28/2004

View Profile



Posted: 05/24/20 09:29am Link  |  Quote  |  Print  |  Notify Moderator

This will happen if the lights are not getting the full 12 volts. Which is often a ground problem. LEDs will work as you described, some lights illuminate a little bit, maybe flicker, and others, like brake, will do nothing.
A multi-meter will only tell you voltage, so checking all connections will not tell you if it is getting a good flow of that 12 volts, which is also called amps.

Check from the vehicle that you get power to all the trailer plug connections.
Check that your trailer plug is not corroded. The 7-pin plugs get a lot of green "rust-looking" mess on it. scrape that off. Use vinegar to help. Disconnect from the camper battery, then dip it in the vinegar, let sit, then use toothbrush or something to clean it.

I prevent this corrosion to a large extent by using a circuit breaker so I can disconnect the 12V positive from the camper battery to the 7-pin plug. This way there is no electrical potential in the moist air around the plug. a 12v positive so close to a 12v negative.

dogvetia

moville iowa usa

Senior Member

Joined: 08/16/2004

View Profile


Offline
Posted: 05/26/20 10:33am Link  |  Quote  |  Print  |  Notify Moderator

thank you all for the good ideas i will pursue


2004 Journey
2006 jeep commander
DW, 4 kids and 11 grandkids to camp with!!!!


drsteve

Michigan

Senior Member

Joined: 06/09/2006

View Profile


Offline
Posted: 05/26/20 06:44pm Link  |  Quote  |  Print  |  Notify Moderator

ajriding wrote:


A multi-meter will only tell you voltage, so checking all connections will not tell you if it is getting a good flow of that 12 volts, which is also called amps.


Truth. The way around this is to use a test lamp rather than a voltmeter. If there's not enough current, the lamp will show it.


2006 Silverado 1500HD Crew Cab 2WD 6.0L 3.73 8600 GVWR
2018 Coachmen Catalina Legacy Edition 223RBS
1991 Palomino Filly PUP

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > no brake lites or hazard but turn signals flicker
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.