Good Sam Club Open Roads Forum: Ripping up carpet, replace with vinyl, fuel pump hatch.
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Ripping up carpet, replace with vinyl, fuel pump hatch.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
maillemaker

office

Senior Member

Joined: 09/08/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 07/25/20 10:10pm Link  |  Quote  |  Print  |  Notify Moderator

So, some back story:

I have a 1990 Winnebago Warrior on an E350 chassis. I have been having fits with the fuel pump. It died in 1993, was replaced with the wrong pump, finally got Airtex to admit they specified the wrong one, they sent me the correct one (E2060S). Got it replaced again. Since 2016 I have been chasing an intermittent shutdown while hot problem. I have replaced nearly every electrical thing on the engine. Replaced fuel filter and high pressure frame rail pump. Never thought about the in-tank pump since it was "brand new".

Well, I finally installed a digital fuel pressure gauge, and finally caught the failure in the act. Typically you have to run on a hot day, and then, when you slow down, it will die like it is out of gas. I initially suspected vapor lock, even though this is a fuel-injected 460 engine. I bound a thermocouple to the return of the fuel rail out of the engine compartment and the temp never got over 128F while driving at interstate speeds. If you stopped and shut off the engine for a few minutes, the temp would go up to about 145F, but as soon as you started the engine it would go back down again. Not a vapor lock problem.

Engine runs about 195-199F with AC on on a hot day. Transmission is about 180F on a hot day. This is from digital gauges I have installed.

Finally, when it died and I caught it in the act, fuel pressure was only 12 PSI on the rail.

Also, I installed a digital ammeter on the high pressure pump, and another on the trunk at the inertial cutoff harness. Thus I could see the current draw from the high pressure pump, and the total current draw of the in-tank pump and the high pressure pump together.

Well, I discovered that they read the same. This clued me in that the in-tank pump was not running. I confirmed this by disconnecting the fuel line from upstream of the high pressure pump - sure enough, no fuel from the tank line. Also, I put a mechanic's stethoscope on the tank - no sound.

So if you google "Ford 460 vapor lock" you will discover that there are countless threads out there with people with this exact same problem. My guess is that their in-tank pump has died, and the high pressure pump usually is able to siphon gas from the tank and pump it up to the engine, unless the fuel temp gets up over 100F. My guess is that when high pressure pump sucks from the tank, the low pressure it creates upstream of the pump is enough to reduce the boiling temperature of the gasoline enough for it to boil and then the high pressure pump cavitates.

Anyway, I had the pump replaced AGAIN, and when they gave it back to me, I hooked it up to 12V power. Sure enough, it did not work. Then I wiggled the spade contacts at the actual pump itself, and lo and behold, the pump started working. The pump worked fine - it just had bad electrical contact at the pump connections!

Well, I had a new Airtex E2060S installed, so I figured what the heck, I've got a new pump now.

Well, as soon as I got it back from the shop, the gas gauge is wandering all over the place from time to time. And the second weekend after I got it back (shop was closed the week after 4th of July) it died AGAIN, same symptoms. Dies while hot, 12 PSI on the rail, no current draw from the in-tank pump, wait 20 minutes and it works fine again.

Well my shop says they will replace the pump again. But I'm tired of having to have the shop do this for me because it involves dropping the tank.

So, to the meat of the story.

This RV has wall-to-wall carpet. I've never liked this, as it gets dirty in a hurry. I would prefer vinyl flooring.

While I'm at it, I want to cut an access hatch in the floor to get at the fuel pump.

I'd like some suggestions on how to go about this, and make a nice looking end result with the hatch in the floor.

Thanks,


1990 Winnebago Warrior. "She may not look like much but she's got it where it counts!"



Tyler0215

Iowa

Senior Member

Joined: 03/13/2013

View Profile


Offline
Posted: 07/26/20 05:46am Link  |  Quote  |  Print  |  Notify Moderator

How many fuel pumps have you had replaced? I lost count. You have a electrical problem, all of those pumps you replaced can't all be bad.

8ntw8tn

Southeast Iowa & Texas Hill Country

Senior Member

Joined: 09/13/2003

View Profile





Offline
Posted: 07/26/20 06:29am Link  |  Quote  |  Print  |  Notify Moderator

As far as replacing the carpet with vinyl...no problem. When we got the current 5er we found the carpet in bedroom had been torn by the slide moving in. (I won't go into the reasons why, but we got the cause cured.) We cut and removed the damaged area and replaced it with good quality self adhesive vinyl squares. They were easy to cut to shape and reposition as necessary.

With regard to the hatch you want to make...so much depends on the position and amount of access you need. The first thing that comes to mind for me is to cut out the size you need and mount it back in with a piano hinge. You'd have to mount something around the edges of the hole you've cut to provide adequate support for when the area may be subjected to someone walking on it. That support could be wood or metal (I'd prefer metal) and secured to the floor with recessed carriage bolts. You'll have to have some type of handle to open the hatch and, depending again on position, that could be as simple as a recessed, folding handle commonly used in travel trunks.

As I indicated earlier, the easier part is replacing the carpet with vinyl. The greater challenge could be making the hatch. Hope this helps.


'08 Chevy Silverado 3500 Duramax;
'10 Carriage Cameo F35FWS
Det 1 56th SOWg

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 07/26/20 06:48am Link  |  Quote  |  Print  |  Notify Moderator

Sounds like low voltage through the fuel pump relay. Not sure if yours has one. earlier models do. initial power was fed via the starter relay, then when oil pressure is seen, the fuel pump was energized by oil pressure sending unit.


Bud
USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker


maillemaker

office

Senior Member

Joined: 09/08/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 07/26/20 07:31am Link  |  Quote  |  Print  |  Notify Moderator

Back around 2013, we were on a trip, and the RV died. The fuel pump relay had burned up. I believe this was a precursor to the pump itself dying. Within a year, the pump itself burned up. When I say "burned up", I mean it had melted the metal of the pump. When this burned up, it also burned up the inertia cutoff switch. This was the OEM pump. It was replaced in 2013. The shop that did the replacement put the wrong pump in. Long story short - Airtex's web site did not take into account a part number change in September 1990 so they gave out the wrong fuel pump part number. Made the gas gauge run backwards. So, I had to have it replaced again with the correct one (E2060S).

This pump probably failed 3-4 years ago but I never knew it or suspected it until I got a digital fuel pressure gauge installed on the fuel rail and caught the failure in the act. I also installed ammeters on the line to the high pressure pump and at the inertial cutoff switch (I would prefer to have installed it at the in-tank-pump itself, but I cannot access it). The pumps are getting the correct amount of voltage and draw the proper amount of current (when the in-tank pump is running).

I believe the problem is simply that Airtex pumps are not quality pumps.

Anyway. Floor time. I'm thinking of cutting out a square opening, and fencing the perimeter with 2x4 or similar framing structure. This will give the hatch and surrounding floor something solid to sit on so there is no give when you walk across it. The removable plug/hatch will be floor foam with sheet metal on top of that, and the vinyl on top of that. I will drill small holes around the perimeter of the vinyl to allow flat-head screws to recess down into the vinyl and bottom out on the sheet metal. This way there will be no screw heads protruding up from the vinyl. I was not going to bother with a hinge as hopefully I won't be removing this hatch often. There will be another piece of sheet metal down on under the floor foam on the bottom "hull" plate of the RV, which I'll install with regular sheet metal screws. This will support the hatch and anyone standing on the hatch. When the hatch is removed, and the bottom hull plate remove, I should have access to the top of the fuel tank.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Ripping up carpet, replace with vinyl, fuel pump hatch.
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.