Good Sam Club Open Roads Forum: Half of one of the trailer's LED brake/signal light is out
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Half of one of the trailer's LED brake/signal light is out

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
profdant139

Southern California

Senior Member

Joined: 11/14/2005

View Profile


Offline
Posted: 10/20/19 05:27pm Link  |  Quote  |  Print  |  Notify Moderator

We check our trailer lights every time we hitch up and roll, just to make sure. Everything has been just fine, till now.

One rear signal light is not working properly, and the other is working OK. The one that is not working right is partially on and partially not. So, for example, when I step on the brakes, the top row of LEDs does not light up, but the bottom one does.

I have checked the 7-pin plug and it is plugged in all the way.

Is this a bad bulb, or something else? I've searched the archive and have come up empty.

Your guidance will be appreciated!


2012 Fun Finder X-139 "Boondock Style" (axle-flipped and extra insulation)
2013 Toyota Tacoma Off-Road (semi-beefy tires and components)
Our trips -- pix and text
About our trailer
"A journey of a thousand miles begins with a single list."


Lwiddis

Veterans’ Park, Monterey, California

Senior Member

Joined: 08/12/2016

View Profile



Good Sam RV Club Member

Offline
Posted: 10/20/19 05:30pm Link  |  Quote  |  Print  |  Notify Moderator

Bad LED unit IMO. Replace it.


Winnebago 2101DS TT & 2020 Chevy Silverado 1500 LTZ Z71, 300 watts solar-parallel & MPPT, Trojan T-125s. TALL pole for flags. Prefer USFS, COE, BLM, NPS, TVA, USF&WS, state & county camps. Bicyclist! 14 year Army vet - 11B40 then 11A - (MOS 1542 & 1560)


STBRetired

I-80 and I-55

Senior Member

Joined: 11/23/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 10/20/19 05:40pm Link  |  Quote  |  Print  |  Notify Moderator

Usually that is an indication of a failed LED light assembly. The individual elements are not replaceable so you must replace the entire LED panel assembly.


1999 Newmar MACA 3796 F53 6.8L
2016 Ford Edge Sport
Roadmaster Sterling A/T with Brake Buddy Select


ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile


Offline
Posted: 10/20/19 05:40pm Link  |  Quote  |  Print  |  Notify Moderator

The lamp assembly itself is bad - a common issue with multi-LED fixtures.
Nothing in the circuit before the lamp fixture can cause a partial failure inside the assy.


Scott, Grace and Wesly
2003 Dodge 3500 4x4, 6 speed Cummins.
2018 Silver Fox 32A.
H0NDA eu2000i

Z-Peller

Oceanside BC

Senior Member

Joined: 07/12/2003

View Profile



Posted: 10/20/19 08:05pm Link  |  Quote  |  Print  |  Notify Moderator

Bad LED's...I just had the same problem with 3 yrs old Bargman....I bought their replacement LED light module....easy to replace..take out 2 screws to pull module off and snip 3 wires ...crimp connect new unit wires on and remount. ....if it is a retrofit unit that replaced 1156 bulbs, then even easier to replace as no wire snipping involved. An 1156 bulb base comes attached to module wires...Take the faulty module out to check which kind before buying new one.


Bill..
2017 Bigfoot 10.4 camper...2016 GMC 3500 4x4 Xcab Duramax Dually...

profdant139

Southern California

Senior Member

Joined: 11/14/2005

View Profile


Offline
Posted: 10/20/19 09:59pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks!!!

Edd505

Elephant Butte, NM

Senior Member

Joined: 05/20/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 10/21/19 10:58am Link  |  Quote  |  Print  |  Notify Moderator

I converted an older 5W to all led and found this place had everything.
http://www.commandelectronics.com/shop


2015 F350 FX4 SRW 6.7 Crew, longbed - 2017 Durango Gold 353RKT
2006 F350 SRW 6.0 crew longbed sold
2000 F250 SRW 7.3 extended longbed airbags sold
2001 Western Star 4900EX sold
Jayco Eagle 30.5BHLT sold, Layton 24.5LT sold


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Half of one of the trailer's LED brake/signal light is out
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS