Good Sam Club Open Roads Forum: Tow Vehicles: Dodge / Chrysler Uconnect Issues
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tow Vehicles

Open Roads Forum  >  Tow Vehicles

 > Dodge / Chrysler Uconnect Issues

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 10/09/19 05:34am Link  |  Quote  |  Print  |  Notify Moderator

Anyone having issues with their Uconnect in the Dodge/Chrysler vehicles? Mine is a 2013 Ram and it had some symptoms, like the volume just went away but if you stopped and turned it off, then back on it reset itself. Now, this happens every time I run the truck. After about 30 min, the volume settings go bye bye, but the worst thing is if you stop and shut off and open the door to get out, the dash and Uconnect stay on and never shut off. The fix so far is to put key back in ignition and go to ACC then back off. It resets and turns the screen back off as to not run down the battery. So, the question is who is having similar issues and what did you do about it? I went through the reset of holding down the volume and tune button at the same time, but no fix.


2013 3500 Cummins 6.7 Quadcab 4x4 3.73 68FE Trans, 2007 HitchHiker Discover America 329 RSB
We love our Westie


dodge guy

Bartlett IL

Senior Member

Joined: 03/23/2004

View Profile


Offline
Posted: 10/09/19 06:01am Link  |  Quote  |  Print  |  Notify Moderator

There is an update for those exact issues. However I have only had one I was able to update. Chrysler is having problems with their updates. The only way I have fixed those was to replace the radio. You can try disconnecting the battery to do a reset, but the problem may come back. Take it to the dealer and see if they can do an update.


Wife Kim
Son Brandon 17yrs
Daughter Marissa 16yrs
Dog Bailey

12 Forest River Georgetown 350TS Hellwig sway bars, BlueOx TrueCenter stabilizer

13 Ford Explorer Roadmaster Stowmaster 5000, VIP Tow>
A bad day camping is
better than a good day at work!


ShinerBock

SATX

Senior Member

Joined: 02/22/2015

View Profile



Posted: 10/09/19 06:47am Link  |  Quote  |  Print  |  Notify Moderator

Yeah, I just had an over the air update last week, but I was not having issues before. You might have to delete and re-pair your phone to the Bluetooth after the update like I did.

JRscooby

Indepmo

Senior Member

Joined: 06/10/2019

View Profile


Offline
Posted: 10/09/19 07:16am Link  |  Quote  |  Print  |  Notify Moderator

ShinerBock wrote:

Yeah, I just had an over the air update last week, but I was not having issues before. You might have to delete and re-pair your phone to the Bluetooth after the update like I did.


No dog in this fight, all my cars are too old. But I have had issues with "updates" on other things. Could a law that required before a product that has been sold could be updated the owner must be told what issues the update is to correct. If the owner had no problem with the issue, they could decide not to take the update. What percentage of the voters could object to this?

Bionic Man

Colorado

Senior Member

Joined: 04/03/2009

View Profile



Posted: 10/09/19 08:04am Link  |  Quote  |  Print  |  Notify Moderator

I had some problems with the Uconnect and head unit in my 2014 Grand Cherokee.

When the dealer tried to do an update it actually crashed the head unit. Getting it replaced was a huge pain.

If you end up needing a new head unit there is an individual I found on Facebook that sells them at a fraction of the cost of new.

Good luck.


2012 RAM 3500 Laramie Longhorn DRW CC 4x4 Max Tow, Cummins HO, 60 gallon RDS aux fuel tank, Reese 18k Elite hitch
2003 Dodge Ram 3500 QC SB 4x4 Cummins HO NV5600 with Smarty JR, Jacobs EB (sold)
2002 Gulf Stream Sea Hawk 29FRB with Honda EV6010

Cummins12V98

on the road

Senior Member

Joined: 06/03/2012

View Profile


Offline
Posted: 10/09/19 08:12am Link  |  Quote  |  Print  |  Notify Moderator

May sound dumb but have you replaced OE batteries?


2015 RAM LongHorn 3500 Dually CrewCab 4X4 CUMMINS/AISIN RearAir 385HP/865TQ 4:10's
37,800# GCVWR "Towing Beast"

"HeavyWeight" B&W RVK3600

2016 MobileSuites 39TKSB3 highly "Elited" In the stable

2007.5 Mobile Suites 36 SB3 29,000# Combined SOLD

swn

California

New Member

Joined: 11/07/2008

View Profile



Good Sam RV Club Member


Posted: 10/09/19 08:28am Link  |  Quote  |  Print  |  Notify Moderator

Like most technology it works except when you want it to work. My Uconnect will suddenly tell me there are no paired phones. When I try to click on the phone listed it doesn't pair. I have to delete and start over to get the phone connected.

Me Again

Sunbird(Wa)/snowbird(Az)

Senior Member

Joined: 09/26/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 10/09/19 08:52am Link  |  Quote  |  Print  |  Notify Moderator

Push and hold the mute and enter buttons at the same time to reboot the system. These are the center of the two knobs. Chris


2015 RAM 3500 CC SB SRW Our Rig New 2017 Bighorn 3575el. Commuter trailer 2019 Laredo 225MK. Retired and enjoying it!


cummins2014

Utah

Senior Member

Joined: 02/20/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 10/09/19 10:29am Link  |  Quote  |  Print  |  Notify Moderator

Cummins12V98 wrote:

May sound dumb but have you replaced OE batteries?



I agree . I know hard to believe [emoticon] My sons 2016 did all kinds of crazy electronic stuff including the radio ,until his batteries were dead one morning ,and he replaced them . Everything went back to normal .

Bedlam

PNW

Moderator

Joined: 06/13/2012

View Profile






Posted: 10/09/19 11:00am Link  |  Quote  |  Print  |  Notify Moderator

I have heard of these problems and opted for the 3.0 version of Uconnect which does not have over the air update connectivity. I know recently FCA was pushing updates out and people had radios continuing to operate even after leaving the vehicle. A second update to these fixed many of the problems brought on by the first update. There are some threads on the Cummins Forum about this issue.

Power resetting the radio may help if it is a logic programming issue since these radios never are really powered down. I think running down the batteries bellow operating voltage resulted in the same and it is NOT a battery problem. The dead batteries were a symptom of a locked up radio draining them.


Chevy Sonic 1.8-Honda Passport C70B-Host Mammoth 11.5-Interstate Car Carrier 20-Joyner SandViper 250-Kawasaki Concours ZG1000-Paros 8' flatbed-Pelican Decker DLX 8.75-Ram 5500 HD-Tank Urban Touring 150SE-VW TransBuggy 1200


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Tow Vehicles

 > Dodge / Chrysler Uconnect Issues
Search:   Advanced Search

Search only in Tow Vehicles


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS