Good Sam Club Open Roads Forum: dead 2015 axis 24.1 chassis
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes

 > dead 2015 axis 24.1 chassis

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
PARDRIVE1

vero beach, fl

New Member

Joined: 09/07/2019

View Profile


Offline
Posted: 09/07/19 12:58pm Link  |  Quote  |  Print  |  Notify Moderator

I changed the chassis battery and now have absolutely NO power to cab. No ignition, no dash lights when key turned...nothing. I'm a plumber not an electrician, and brand new to RV. Gotta be a simple fix, but I can't find it. HELP>

* This post was edited 09/07/19 02:21pm by PARDRIVE1 *

Flute Man

Payson, Arizona

Full Member

Joined: 03/21/2019

View Profile


Offline
Posted: 09/07/19 01:02pm Link  |  Quote  |  Print  |  Notify Moderator

Is it possible that you hooked up the battery backwards.

Jerry Parr


Jerry Parr
05 Mandalay 40B
Cat C7 350
04 Honda CR-V
Ham Radio K7OU
Retired EE
[email protected]
602-321-8141
Full-timer

1492

Arlington, VA

Moderator

Joined: 04/08/2005

View Profile



Posted: 09/08/19 09:51pm Link  |  Quote  |  Print  |  Notify Moderator

Moved from Forum Posting Help and Support

oldave

Tx

Full Member

Joined: 06/19/2018

View Profile



Good Sam RV Club Member

Offline
Posted: 09/09/19 07:42am Link  |  Quote  |  Print  |  Notify Moderator

It would help to know what rv you have .

Usually when this happens something has been wired up wrong or
a wire has been left off .
Look around the battery compartment to see if a wire has fallen
down out of sight .
This may be a small wire , not necessarily a cable .

Did you take a picture or draw one ? Always take a picture several
pictures are even better . Memory will not always work .

way2roll

Wilmington NC

Senior Member

Joined: 10/05/2018

View Profile


Offline
Posted: 09/09/19 09:06am Link  |  Quote  |  Print  |  Notify Moderator

oldave wrote:

It would help to know what rv you have .

Usually when this happens something has been wired up wrong or
a wire has been left off .
Look around the battery compartment to see if a wire has fallen
down out of sight .
This may be a small wire , not necessarily a cable .

Did you take a picture or draw one ? Always take a picture several
pictures are even better . Memory will not always work .


The title for the post says it's an AXIS 24.1.

To the OP - if you replaced the battery and nothing works, my guess is you didn't hook something up correctly. Hopefully you didn't hook the battery up backwards. Did you miss a ground?

rgatijnet1

Florida

Senior Member

Joined: 06/22/2009

View Profile



Good Sam RV Club Member


Posted: 09/09/19 09:10am Link  |  Quote  |  Print  |  Notify Moderator

Did you forget to throw the battery disconnect switch after you changed the batteries?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes

 > dead 2015 axis 24.1 chassis
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS